
ECE 453/553 Programming 
Assignment 2 
Wireshark Labs 

Instructions: 
Please complete this assignment by individuals, in the same way that you complete homework 

assignments. Both graduate and undergraduate students are expected to complete this 

programming assignment.  

Goals 
One’s understanding of network protocols can often be greatly deepened by “seeing protocols in 

action” and by “playing around with protocols” – observing the sequence of  messages exchanged 

between two protocol entities, delving down into the details of protocol operation, and causing 

protocols to perform certain actions and then observing these actions and their consequences. 

This can be done in simulated scenarios or in a “real” network environment such as the Internet. 

In this assignment, we’ll take the latter approach.   

 

You’ll be running various network applications in different scenarios using a computer on your 

desk, at home, or in a lab. You’ll observe the network protocols in your computer “in action,” 

interacting and exchanging messages with protocol entities executing elsewhere in the Internet.   

Thus, you and your computer will be an integral part of these “live” labs.  You’ll observe, and 

you’ll learn, by doing.  

 

This lab is organized into five parts. At the end of each part that are a series of questions that you 

are going to solve. Unlike the first programming assignment, this one is supposed to be solved by 

individuals instead of teams, much like the way that you prepare your homework solutions. To 

earn credit, you need to finish each part of this lab using Wireshark software and submit a report, 

containing your experiment results in the form of screenshots and calculations. We expect that 

your solutions will be unique: it depends on the network environment you have, your IP and 

MAC addresses, and the computer configurations. Therefore, as you work on this project 

independently, we expect each report will contain different answers for certain questions. By the 

end of this lab, you will find that you have learnt a lot on the details of various network protocols 

through hands-on experiments.  



PART I: Get started   
This lab assignment assumes that you have access to a computer that 1) you may install 

applications; 2) it is connected to the Internet. It could be a laptop or a desktop. If you do not have 

such access, some computers in the lab will be installed with the needed software by the technical 

staff. Please contact us for the details.  

  

The basic tool for observing the messages exchanged between executing protocol entities is 

called a packet sniffer.  As the name suggests, a packet sniffer captures (“sniffs”) messages being 

sent/received from/by your computer; it will also typically store and/or display the contents of the 

various protocol fields in these captured messages. A packet sniffer itself is passive. It observes 

messages being sent and received by applications and protocols running on your computer, but 

never sends packets itself. Similarly, received packets are never explicitly addressed to the packet 

sniffer.  Instead, a packet sniffer receives a copy of packets that are sent/received from/by 

application and protocols executing on your machine.  

 

Figure 1 shows the structure of a packet sniffer. At the right of Figure 1 are the protocols (in this 

case, Internet protocols) and applications (such as a web browser or ftp client) that normally run 

on your computer.  The packet sniffer, shown within the dashed rectangle in Figure 1 is an 

addition to the usual software in your computer, and consists of two parts.  The packet capture 

library receives a copy of every link-layer frame that is sent from or received by your computer.  

Note that here messages that are exchanged by higher layer protocols  such as HTTP,  FTP, TCP, 

UDP, DNS, or IP all are eventually encapsulated in link-layer frames that are  transmitted over 

physical media such as an Ethernet cable.  (Don’t worry about HTTP or TCP as we have not 

talked about it. This lab contains minimal exposure to these two protocols. )  In Figure 1, the 

assumed physical media is an Ethernet, and so all upper layer protocols are eventually 

encapsulated within an Ethernet frame.  Capturing all link-layer frames thus gives you all 

messages sent/received from/by all protocols and applications executing in your computer.  

 

                                                   



 

The second component of a packet sniffer is the packet analyzer, which displays the contents of 

all fields within a protocol message.  In order to do so, the packet analyzer must “understand” the 

structure of all messages exchanged by protocols.  For example, suppose we are interested in 

displaying the various fields in messages exchanged by the UDP protocol in Figure 1. The packet 

analyzer understands the format of Ethernet frames, and so can identify the IP datagram within an 

Ethernet frame.  It also understands the IP datagram format, so that it can extract the UDP 

segment within the IP datagram.  It will then display the contents of UDP packets for your 

analysis.  

 

 We will be using the Wireshark packet sniffer [http://www.wireshark.org/] for these labs,  

allowing us to display the contents of messages being sent/received from/by protocols at different 

levels of the protocol stack.  (Technically speaking, Wireshark is a packet analyzer that uses a 

packet capture library in your computer). Wireshark is a free network protocol analyzer that runs 

on Windows, Linux/Unix, and Mac computers. It’s an ideal packet analyzer for our labs – it is 

stable, has a large user base and well-documented support that includes a user-guide 

(http://www.wireshark.org/docs/wsug_html_chunked/), man pages 

(http://www.wireshark.org/docs/man-pages/), and a detailed FAQ 

(http://www.wireshark.org/faq.html), rich functionality that includes the capability to analyze 

hundreds of protocols, and a well-designed user interface. It operates in computers using Ethernet, 

Token-Ring, FDDI, serial (PPP and SLIP), 802.11 wireless LANs, and ATM connections (if the 

OS on which it's running allows Wireshark to do so). 

 

Getting Wireshark  
 

In order to run Wireshark, you will need to have access to a computer that supports both 

Wireshark and the libpcap or WinPCap packet capture library. The libpcap software will be 

installed for you, if it is not installed within your operating system, when you install Wireshark. 

See http://www.wireshark.org/download.html for a list of supported operating systems and 

download sites Download and install the Wireshark software:  

•  Go to http://www.wireshark.org/download.html and download and install the Wireshark binary 

for your computer.   

•  Download the Wireshark user guide.    

The Wireshark FAQ has a number of helpful hints and interesting tidbits of information, 

particularly if you have trouble installing or running Wireshark.  

Running Wireshark 
 

When you run the Wireshark program, the Wireshark graphical user interface shown in Figure 2 

will be displayed. Initially, no data will be displayed in the various windows. 



 

The Wireshark interface has five major components:  

 The command menus are standard pulldown menus located at the top of the window.  Of 

interest to us now are the File and Capture menus.  The File menu allows you to save 

captured packet data or open a file containing previously captured packet data, and exit 

the Wireshark application.  The Capture menu allows you to begin packet capture. 

 The packet-listing window displays a one-line summary for each packet captured, 

including the packet number (assigned by Wireshark; this is not a packet number 

contained in any protocol’s header), the time at which the packet was captured, the 

packet’s source and destination addresses, the protocol type, and protocol-specific 

information contained in the packet. The packet listing can be sorted according to any of 

these categories by clicking on a column name.  The protocol type field lists the highest 

level protocol that sent or received this packet, i.e., the protocol that is the source or 

ultimate sink for this packet.  

 The packet-header details window provides details about the packet selected 

(highlighted) in the packet listing window.  (To select a packet in the packet listing 

window, place the cursor over the packet’s one-line summary in the packet listing 

window and click with the left mouse button.).  These details include information about 

the Ethernet frame (assuming the packet was sent/received over an Ethernet interface) 

and IP datagram that contains this packet. The amount of Ethernet and IP-layer detail 

displayed can be expanded or minimized by clicking on the plus-or-minus boxes to the 



left of the Ethernet frame or IP datagram line in the packet details window.  If the packet 

has been carried over TCP or UDP, TCP or UDP details will also be displayed, which can 

similarly be expanded or minimized.  Finally, details about the highest level protocol that 

sent or received this packet are also provided.  

 The packet-contents window displays the entire contents of the captured frame, in both 

ASCII and hexadecimal format.  

 Towards the top of the Wireshark graphical user interface, is the packet display filter 

field, into which a protocol name or other information can be entered in order to filter the 

information displayed in the packet-listing window (and hence the packet-header and 

packet-contents windows).  In the example below, we’ll use the packet-display filter field 

to have Wireshark hide (not display) packets except those that correspond to HTTP 

messages. 

Taking Wireshark for Test Run 
 

The best way to learn about any new piece of software is to try it out!  We’ll assume that your 

computer is connected to the Internet via a wired Ethernet interface. If you use a laptop that only 

has wireless connection, this will also be fine with the following experiments.  Do the following: 

1.  Start up your favorite web browser, which will display your selected homepage.  

2.  Start up the Wireshark software.  You will initially see a window similar to that shown in 

Figure 2, except that no packet data will be displayed in the packet-listing, packet-header, or 

packet-contents window, since Wireshark has not yet begun capturing packets.   

3.  To begin packet capture, select the Capture pull down menu and select Options. This will 

cause the “Wireshark: Capture Options” window to be displayed, as shown in Figure 3.  

4.  You can use most of the default values in this window, but uncheck “Hide capture info dialog” 

under Display Options.  The network interfaces (i.e., the physical connections) that your 

computer has to the network will be shown in the Interface pull down menu at the top of the 

Capture Options window. In case your computer has more than one active network interface (e.g., 

if you have both a wireless and a wired Ethernet connection), you will need to select an interface 

that is being used to send and receive packets (mostly likely the wired interface). After selecting 

the network interface (or using the default interface chosen by Wireshark), click Start.  Packet 

capture will now begin - all packets being sent/received from/by your computer are now being 

captured by Wireshark!  

5.  Once you begin packet capture, a packet capture summary window will appear, as shown in 

Figure 4.  This window summarizes the number of packets of various types that are being 

captured, and (importantly!) contains the Stop button that will allow you to stop packet capture.  

Don’t stop packet capture yet. 



                 

6.  While Wireshark is running, enter the URL:   

        http://google.com 

and have that page displayed in your browser. In order to display this page, your browser will 

contact the HTTP server at google.com and exchange HTTP messages with the server in order to 

download this page.  The Ethernet frames containing these HTTP messages will be captured by 

Wireshark.  

 7.  After your browser has displayed the web page, stop Wireshark packet capture by selecting 

stop in the Wireshark capture window.  This will cause the Wireshark capture window to 

disappear and the main Wireshark window to display all packets captured since you began packet 

capture.  The main Wireshark window should now look similar to Figure 2. You now have live 

packet data that contains all protocol messages exchanged between your computer and other 

network entities!  The HTTP message exchanges with the google.com should appear somewhere 

in the listing of packets captured.  But there will be many other types of packets displayed as well 

(see, e.g., the many different protocol types shown in the Protocol column in Figure 2).  Even 

though the only action you took was to download a web page, there were evidently many other 

protocols running on your computer that are unseen by the user.  We’ll learn much more about 

these protocols as we progress through the experiments.  For now, you should just be aware that 

there is often much more going on than “meets the eye”!  

  



8.  Type in “http” (without the quotes, and in lower case – all protocol names are in lower case in 

Wireshark) into the display filter specification window at the top of the main Wireshark window.  

Then select Apply (to the right of where you entered “http”).  This will cause only HTTP 

message to be displayed in the packet-listing window.    

9.  Select the first http message shown in the packet-listing window.  This should be the HTTP 

GET message that was sent from your computer to the google.com HTTP server.  When you 

select the HTTP GET message, the Ethernet frame, IP datagram, TCP segment, and HTTP 

message header information will be displayed in the packet-header window. By clicking plus-

and-minus boxes to the left side of the packet details window, minimize the amount of Frame, 

Ethernet, Internet Protocol, and Transmission Control Protocol information displayed.  Maximize 

the amount information displayed about the HTTP protocol.  Your Wireshark display should now 

look roughly as shown in Figure 4 or Figure 5(displayed on a few pages later). Note that the 

maximized amount of protocol information for HTTP is displayed in the packet-header window.  

 

 Figure 4 Screenshot of Wireshark 

10. Exit   

Assignment for Part I 
 

The goal of this first part was primarily to introduce you to Wireshark. The following questions 

will demonstrate that you’ve been able to get Wireshark up and running, and have explored some 

of its capabilities. Answer the following questions, based on your Wireshark experimentation:  

  



1.  List up to 10 different protocols that appear in the protocol column in the unfiltered packet-

listing window in step 7 above.  

2.  How long did it take from when the HTTP GET message was sent until the HTTP OK reply 

was received? (By default, the value of the Time column in the packet listing window is the 

amount of time, in seconds, since Wireshark tracing began.  To display the Time field in time-

of-day format, select the Wireshark View pull down menu, then select Time Display Format, 

then select Time-of-day. For now you don’t need to understand HTTP GET and OK, but 

reading the textbook may be helpful if you are curious on how they work.)  

3.  What is the Internet address of the www.google.com?  What is the Internet address of your 

computer?  

4.  Provide a similar screenshot to the Figure 4 with Wireshark running on your computer.  

(Each question 5 points, total 20 points) 

PART II: Experiments with Ethernet 
 

In this lab, we’ll investigate the Ethernet protocol and the ARP protocol.   RFC 826 

(http://www.faqs.org/rfcs/rfc826.html) contains the details of the ARP protocol, which is used by 

an IP device to determine the IP address of a remote interface whose Ethernet address is known.  

Capturing and analyzing Ethernet frames  
Let’s begin by capturing a set of Ethernet frames to study.  Do the following:  

•  First, make sure your browser’s cache is empty. (To do this under Netscape 7.0, select Edit-

>Preferences->Advanced->Cache and clear the memory and disk cache. For Internet Explorer, 

select Tools->Internet Options->Delete Files.  For Firefox select Tools->Clear Private Data.  

•  Start up the Wireshark packet sniffer  

•  Enter the following URL into your browser  

http://www.faqs.org/rfcs/rfc826.html  

You should see the contents of the RFC.  

•  Stop Wireshark packet capture. First, find the packet numbers (the leftmost column in the 

upper Wireshark window) of the HTTP GET message that was sent from your computer to the 

URL above, as well as the beginning of the HTTP response message sent to your computer.  You 

should see a screen that looks something like this (where the selected in the screen shot below 

contains the HTTP GET message)  



 

 

Since this lab is about Ethernet, we’re not interested in IP or higher-layer protocols. So let’s 

change Wireshark’s “listing of captured packets” window so that it shows information only about 

protocols below IP. To have Wireshark do this, select Analyze->Enabled Protocols.  Then 

uncheck the IP box and select OK.   

You should now see a Wireshark window that looks like: 



 

In order to answer the following questions, you’ll need to look into the packet details and packet 

contents windows (the middle and lower display windows in Wireshark).  

 Select the Ethernet frame containing the HTTP GET message. (Recall that the HTTP GET 

message is carried inside of a TCP segment, which is carried inside of an IP datagram, which is 

carried inside of an Ethernet frame) Expand the Ethernet II information in the packet details 

window.  Note that the contents of the Ethernet frame (header as well as payload) are displayed in 

the packet contents window. 

Assignment for Part II 
Answer the following questions, based on the contents of the Ethernet frame containing the 

HTTP GET message. Whenever possible, when answering a question you should hand in a 



selection of the packet(s) within the trace that you used to answer the question asked, or a 

screenshot with annotations.  

1.  What is the 48-bit Ethernet address of your computer?  

2.  What is the 48-bit destination address in the Ethernet frame?  Is this the Ethernet address of 

the website with the RFC? (Hint: the answer is no).  What device has this as its Ethernet 

address? 

3.  Give the hexadecimal value for the two-byte Frame type field.  What do the bit(s) whose 

value is 1 mean within the flag field?  (Refer to the RFC, or resources on the Internet to find 

the answer) 

4.  How many bytes from the very start of the Ethernet frame does the ASCII “G” in “GET” 

appear in the Ethernet frame?  

 Next, answer the following questions, based on the contents of the Ethernet frame containing 

the first byte of the HTTP response message.  

5.  What is the value of the Ethernet source address?  Is this the address of your computer, or 

of the destination website (Hint: the answer is no).   What device has this as its Ethernet 

address?  

6.  What is the destination address in the Ethernet frame?  Is this the Ethernet address of your 

computer?   

7.  Give the hexadecimal value for the two-byte Frame type field.  What do the bit(s) whose 

value is 1 mean within the flag field?  

(each question 3 points. Total 21 points) 

 

PART III: Experiments with IP 
 

In this lab, we’ll investigate the IP protocol, focusing on the IP datagram. We’ll do so by 

analyzing a trace of IP datagrams sent and received by an execution of the traceroute program. 

We’ll investigate the various fields in the IP datagram, and study IP fragmentation in detail.   

 During this part, you will probably want to refer to RFC 2151 

(http://www.faqs.org/rfcs/rfc2151.html) to get the details on the operation of the traceroute 

program.  You probably also have RFC 791 [ftp://ftp.rfc-editor.org/in-notes/rfc791.txt] on hand 

as well, for a discussion of the IP protocol. 

http://www.faqs.org/rfcs/rfc2151.html


Capturing packets during the operation of the traceroute command 
In order to generate a trace of IP datagrams for this lab, we’ll use the traceroute program to send 

datagrams of different sizes towards some destination, X.  Traceroute operates by first sending 

one or more datagrams with the time-to-live (TTL) field in the IP header set to 1; it then sends a 

series of one or more datagrams towards the same destination with a TTL value of 2; it then sends 

a series of datagrams towards the same destination with a TTL value of 3; and so on.  Recall that 

a router must decrement the TTL in each received datagram by 1 (actually, RFC 791 says that the 

router must decrement the TTL by at least one). If the TTL reaches 0, the router returns an ICMP 

message (type 11 – TTL-exceeded) to the sending host. As a result of this behavior, a datagram 

with a TTL of 1 (sent by the host executing traceroute) will cause the router one hop away from 

the sender to send an ICMP TTL-exceeded message back to the sender; the datagram sent with a 

TTL of 2 will cause the router two hops away to send an ICMP message back to the sender; the 

datagram sent with a TTL of 3 will cause the router three hops away to send an ICMP message 

back to the sender; and so on.  In this manner, the host executing traceroute can learn the 

identities of the routers between itself and destination X by looking at the source IP addresses in 

the datagrams containing the ICMP TTL-exceeded messages.  

We’ll want to run traceroute and have it send datagrams of various lengths. 

Windows.  The tracert program provided with Windows does not allow one to change the size of 

the ICMP echo request (ping) message sent by the tracert program. A nicer Windows traceroute 

program is pingplotter, available both in free version and shareware versions at 

http://www.pingplotter.com. Download and install pingplotter, and test it out by performing a few 

traceroutes to your favorite sites.  You may want to try the standard version which has a 30-day 

trial period. You do not need to purchase this software to finish this experiment. The size of the 

ICMP echo request message can be explicitly set in pingplotter by selecting the menu item Edit-> 

Options->Packet Options and then filling in the Packet Size field.  The default packet size is 56 

bytes.  Once pingplotter has sent a series of packets with the increasing TTL values, it restarts the 

sending process again with a TTL of 1, after waiting Trace Interval amount of time. The value of 

Trace Interval and the number of intervals can be explicitly set in pingplotter.  

Linux/Unix.  With the Unix traceroute command, the size of the UDP datagram sent towards the 

destination can be explicitly set by indicating the number of bytes in the datagram; this value is 

entered in the traceroute command line immediately after the name or address of the destination.  

For example, to send traceroute datagrams of 2000 bytes towards cnn.com, the command would 

be: %traceroute cnn.com 2000 

On Mac computers, programs similar to Linux should be available in the terminal environment of 

MAC OSX.  

Do the following:  

•  Start up Wireshark and begin packet capture (Capture->Option) and then press OK on the 

Wireshark Packet Capture Options screen (we’ll not need to select any options here).  



•  If you are using a Windows platform, start up pingplotter and enter the name of a target 

destination in the “Address to Trace Window.”  Enter 3 in the “# of times to Trace” field, so you 

don’t gather too much data.  Select the menu item Edit->Advanced Options->Packet Options and 

enter a value of 56 in the Packet Size field and then press OK.  Then press the Trace button.  You 

should see a pingplotter window that looks something like this:  

 

Next, send a set of datagrams with a longer length, by selecting Edit->Advanced Options->Packet 

Options and enter a value of 2000 in the Packet Size field and then press OK. Then press the 

Resume button.   

Finally, send a set of datagrams with a longer length, by selecting Edit->Advanced Options-

>Packet Options and enter a value of 3500 in the Packet Size field and then press OK.  Then 

press the Resume button.  

  

Stop Wireshark tracing.  

If you are using a Unix platform, enter three traceroute commands, one with a length of 56 bytes, 

one with a length of 2000 bytes, and one with a length of 3500 bytes.  

Stop Wireshark tracing. 

 



Assignment for Part III 
In your trace, you should be able to see the series of ICMP Echo Request (in the case of Windows 

machine) or the UDP segment (in the case of Unix) sent by your computer and the ICMP TTL-

exceeded messages returned to your computer by the intermediate routers.  In the questions below, 

we’ll assume you are using a Windows machine; the corresponding questions for the case of a 

Unix machine should be clear. Whenever possible, when answering a question you should hand 

in a screenshot of the packet(s) containing the trace that you used to answer the question asked.   

1 Select the first ICMP Echo Request message sent by your computer, and expand the Internet 

Protocol part of the packet in the packet details window.   What is the IP address of your 

computer?  

2 Within the IP packet header, what is the value in the upper layer protocol field?  

3 How many bytes are in the IP header? How many bytes are in the payload of the IP 

datagram?  Explain how you determined the number of payload bytes.  

4 Has this IP datagram been fragmented?  Explain how you determined whether or not the 

datagram has been fragmented. 

Next, sort the traced packets according to IP source address by clicking on the Source column 

header; a small downward pointing arrow should appear next to the word Source.  If the arrow 

points up, click on the Source column header again.  Select the first ICMP Echo Request message 

sent by your computer, and expand the Internet Protocol portion in the “details of selected packet 

header” window.  In the “listing of captured packets” window, you should see all of the 

subsequent ICMP messages (perhaps with additional interspersed packets sent by other protocols 

running on your computer) below this first ICMP.  Use the down arrow on your keyboard to 

move through the ICMP messages sent by your computer.   Answer the following questions.  

5 Which fields in the IP datagram always change from one datagram to the next within this 

series of ICMP messages sent by your computer?  

6.  Which fields stay constant?  Which of the fields must stay constant? Which fields must 

change?  Why?  

Next (with the packets still sorted by source address) find the series of ICMP TTL-exceeded 

replies sent to your computer by the nearest (first hop) router.  

7.  What is the value in the Identification field and the TTL field?  Do these values remain 

unchanged for all of the ICMP TTL-exceeded replies sent to your computer by the nearest 

(first hop) router?  Why? 

 

 
 



Now change the packet size to 2000.  (You may skip this if you have already changed the packet 

size in the previous steps). Find the first ICMP Echo Request message that was sent by your 

computer after you changed the Packet Size in pingplotter to be 2000. Has that message been 

fragmented across more than one IP datagram?  [Note: if you find your packet has not been 

fragmented, you should download the larger file, such as ZIP file somewhere on the web. One 

such zip file has been prepared for you, available at 

http://web.eecs.utk.edu/~qcao1/ece453/data.zip.  

 If your computer has an Ethernet interface, a packet size of 2000 should cause fragmentation. 

8 Print out the first fragment of the fragmented IP datagram. What information in the IP 

header indicates that the datagram been fragmented?  What information in the IP header 

indicates whether this is the first fragment versus a latter fragment?  How long is this IP 

datagram?  

9 Print out the second fragment of the fragmented IP datagram. What information in the IP 

header indicates that this is not the first datagram fragment?  Are the more fragments?  How 

can you tell?  

10 What fields change in the IP header between the first and second fragment? 

(two points each, total 20 points) 

PART IV: Experiments with Ping  
Let’s begin our ICMP adventure by capturing the packets generated by the Ping program. You 

may recall that the Ping program is simple tool that allows anyone (for example, a network 

administrator) to verify if a host is live or not. The Ping program in the source host sends a packet 

to the target IP address; if the target is live, the Ping program in the target host responds by 

sending a packet back to the source host. As you might have guessed, based on the previous lab, 

both of these Ping packets are ICMP packets.   

Let’s begin this adventure by opening the Windows Command Prompt application (which can be 

found in your Accessories folder).   

Start up the Wireshark packet sniffer, and begin Wireshark packet capture. The ping command is 

in c:\windows\system32, so type either “ping –n 10 hostname” or “c:\windows\system32\ping –n 

10 hostname” in the MS-DOS command line (without quotation marks), where hostname may be 

a host on another continent. You may choose any website you want. We use google.com as an 

example.  

http://web.eecs.utk.edu/~qcao1/ece453/data.zip


Here, “-n 10” indicates that 10 ping messages should be sent. Then run the Ping program by 

typing return.  

When the Ping program terminates, stop the packet capture in Wireshark.  At the end of the 

experiment, your Wireshark window could look something like the following.  

 

 

The above figure provides a screenshot of the Wireshark output, after “icmp” has been entered 

into the filter display window.  Note that the packet listing shows 20 packets: the 10 Ping queries 

sent by the source and the 10 Ping responses received by the source. Also note that the source’s 

IP address is a private address (behind a NAT) of the form 192.168/12; the destination’s IP 

address is that of the Web server at google.com. Now let’s zoom in on the first packet (sent by the 

client); in the figure below, the packet contents area provides information about this packet. You 

will find that the IP datagram within this packet has protocol number 01, which is the protocol 

number for ICMP. This means that the payload of the IP datagram is an ICMP packet. 



If we focus on the same ICMP but have expanded the ICMP protocol information in the packet 

contents window, we can see that this ICMP packet is of Type 8 and Code 0 - a so-called ICMP 

“echo request” packet. Also note that this ICMP packet contains a checksum, an identifier, and a 

sequence number. 

When answering the following questions, you should provide similar screenshots and use them to 

support your answers. The lab contains the following questions.  

Questions for Part IV (5 points each, total 15 points) 
 

1.  Examine one of the ping request packets sent by your host. What are the ICMP type and 

code numbers? What other fields does this ICMP packet have? How many bytes are the 

checksum, sequence number and identifier fields?  

2.  Examine the corresponding ping reply packet. What are the ICMP type and code numbers? 

What other fields does this ICMP packet have? How many bytes are the checksum, sequence 

number and identifier fields? 

3. Examine the consecutive ICMP packets. Verify the RTT time reported in the command 

window is the same as the timestamps you observe via Wireshark.  (Providing screenshots for 

command windows is helpful to demonstrate your results. ) 

PART V: Experiments with UDP 
In this lab, we’ll take a look at the UDP transport protocol.  Because UDP is simple and sweet, 

we’ll be able to cover it pretty quickly in this lab.  

At this stage, you should be a Wireshark expert. Thus, we are not going to spell out the steps as 

explicitly as in earlier labs. In particular, we are not going to provide example screenshots for all 

the steps.    

Start capturing packets in Wireshark and then do something that will cause your host to send and 

receive several UDP packets. (One way to do this would be to use the nslookup command. The 

nslookup command sends the query to the default DNS (domain name) server, and returns the ip 

address of the domain name.  For example, if you use the command “nslookup utk.edu” in the 

command line, this command is saying “Please send me the IP address for the host www.utk.edu.”  

If you try this on your machine, you will notice that the response from this command provides 

two pieces of information: (1) the name and IP address of the DNS server that provides the 

answer; and (2) the answer itself, which is the host name and IP address of www.utk.edu. 

Although the response came from the local DNS server depending on your location, it is quite 

possible that this local DNS server iteratively contacted several other DNS servers to get the 

answer.  



 After stopping packet capture, set your packet filter so that Wireshark only displays the UDP 

packets sent and received at your host. Pick one of these UDP packets and expand the UDP fields 

in the details window.  

 Now finish the following: (6 questions 4 points each) 

1.  Select one packet. From this packet, determine how many fields there are in the UDP 

header. Name these fields. You may find the UDP packet format in the textbook useful, as well 

as the following link, which is the RFC for UDP. 

http://www.faqs.org/rfcs/rfc768.html 

2.  From the packet content field, determine the length (in bytes) of each of the UDP header 

fields.  

3.  The value in the Length field is the length of what? Verify your claim with your captured 

UDP packet.   

4.  What is the protocol number for UDP? Give your answer in both hexadecimal and decimal 

notation. (To answer this question, you’ll need to look into the IP header.)  

5. Refer to the textbook and see how UDP checksum is calculated. Select a small UDP packet. 

Manually verify the checksum in this packet. Show all work and explain all steps.   

6.  Examine a pair of UDP packets in which the first packet is sent by your host and the second 

packet is a reply to the first packet. Describe the relationship between the port numbers in the 

two packets.   

  

Summary: what to turn in: 
 

For these questions in this assignment, please prepare a report with the solutions to all the 

problems. Your answers should be supported by appropriate screenshots with annotations 

showing which parts are relevant to your answers. If your answers are not supported with 

screenshots when needed, points will be deducted. Please don’t leave any questions un-answered. 

In total, you will need to finish 4 questions for part I, 7 questions for part II, 10 questions for part 

III, 3 questions for part IV, and 6 questions for part V. Your answers will be graded based on 1) 

correctness, 2) completeness with necessary screenshots, and 3) necessary descriptions and 

explanations of your answers.   

 


